DiecastXchange Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1,314 Posts
I know there has been much of this topic talked of lately but i want to add my thoughts. For the last 3 to 4 months, i have been purchasing various Auto Art models that seem to have quality control issues. I will list them with the problems.

1-Bugati Veyron (Black/Red) Missing rear passenger side caliper
2-BMW M3 Watson (White/Green) Same as above
3-MB 190E 2.5 Evo (Black) Wrong writing on engine
4-Ford Mustang 2005 (Red) Tailight fell off

Today, i went to my favorite store excited about buying the new Ford Shelby Concept. I took it out of the box for close inspection. Not there most detailed (in my opinion)
but the problem was the (Powered by Ford) on the valve cover. the driver's side was updide down.

I know that nothing is perfect but with the rising cost of these cars, i am expecting more than what i am finding. I was a big Auto Art fan but cannot figure them out. I have emailed them with my concerns (defect on my cars) with no reply. Now when i go shopping, i am really dissapointed with their products. The prices are high and quality is down.

Well, that was my 2 cents! Thanks for reading

DC4ME
 

·
Registered
Joined
·
153 Posts
I do no know these defects listed by you but the one I know is the Mercedes 190E with the engine spelling mistake. Furthermore they still want to increase their price while quality control has been dropped. There is a change in the management, I think!
 

·
Registered
Joined
·
290 Posts
DC4ME said:
I know there has been much of this topic talked of lately but i want to add my thoughts. For the last 3 to 4 months, i have been purchasing various Auto Art models that seem to have quality control issues. I will list them with the problems.

3-MB 190E 2.5 Evo (Black) Wrong writing on engine
Just wait until they fix the problem and the "misspelled" cars become real collectors items. :giggle

Remember the postage stamps where the airplane was printed upside down?
 

·
Advanced Newtype
Joined
·
1,710 Posts
good news (or bad? :confused). The 190 EVO2's mispelling has been corrected. I saw my local store's newly stocked EVO2, and it has correct engine spelling.

Let's add a bit more to the recent QC issues:

1) missing airbox on Kwan (not me)
2) loose brake caliper on EVO2 (saw at store, NIB)
3) glue stains on plastic bumper (Ztune, mine)
4) "dull" paint (on a RX8 LE, the boot lid)
5) paint chip (on blue Sti)
 
G

·
No problems with my AUTOart 53 vette. The only thing I could bring up would be the Muira...I had some black paint tiny chips off in the engine bay where orange would show through. Maybe a pin prick size wise. Sharpie marker took care of it. Other than that very very minor issue, npf

<{POST_SNAPBACK}>[/post][/right]
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top