DiecastXchange Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
4,471 Posts
Discussion Starter · #1 ·
I had been to my local hobby store to get my XJ 13 and i noticed a little problem with the car. The labels "TOTAL" on the seat belts were missing. So last night I checked diecast.org for the review of the car and the labels were in place. I again called up my hobby shop guy today and asked him to check the seatbelts and he confirmed the missing labels. Also the chrome on the rear signal lights was not up to the mark. Not the smooth chrome we get to see even in budget cars like Maisto. The box was labelled as a April 2005 product.
Here is the link to the review. Jaguar XJ 13 review
My question to you guys who own the car and also to you who get to see the car (maybe in a sattelite garage. :wink Jacob) is, do your XJ13s have the labels on the seatbelts. I would expect AUTOart to add stuff to the car rather than subtracting it. I am in quite a fix now. As badly as I want the car, I cannot stand such discrepancies in a premium model. Thanks all. :cheers
 

·
Advanced Newtype
Joined
·
1,710 Posts
http://www.bcgator.net/Reviews/AAJaguarXJ13.htm

Looking at the pics, BCGator has the TOTAL on the seatbelts as well! What about the backlights? Does your XJ13 look like that?

I'm 85% sure my XJ13 has TOTAL on the seatbelts. I'll double check for you tonight, if no one else has answered your question.
 
G

·
The seatbelts on mine are labeled Winston. Autoart is doing so many models now I'm not at all surprised that small details get overlooked. I'd say try to find a vendor that still has older stock sitting around if you can.
 
G

·
Strange :confused

Is the model mint?

Did you check with the 1:1 ? maybe some details were wrong in the 'more detailed' version
 

·
Advanced Newtype
Joined
·
1,710 Posts
btw, how does one check to see when the model was released? Where does it say "Apr 2005" on your box, Winston?
 

·
Registered
Joined
·
4,471 Posts
Discussion Starter · #7 ·
Thanks for the quick replies guys.

Gary, the review you linked is quite an old one. I can say almost 2 years old if I am not mistaken. Thats from the first lot of the XJ13s. The chrome surrounds around the lenses are of pretty bad quality. Its not smooth but flaky looking. Like there was some solvent put on it and it dissolved the chrome.
All things imported into India have to have a label mentioning the date of manufacture and/or packaging. The label clearly says mfg/packed April 2004. I am not sure if the importer as put the label on the box.

Tom, I really doubt the older models will be lying around here. When they first came, only a few pieces were imported and they were all taken in a few days. Those days my list was long and my pockets had big holes.

Bernard, the model is in mint condition. It was opened in front of me. Those guys are like family now. :giggle So no question of being taken for a ride.
 

·
Advanced Newtype
Joined
·
1,710 Posts
Very interesting. Does this mean QC has slipped at AUTOart? Or was this an unfortunate one-off?

I will check mine tonight, and take pics. But I'm pretty sure mine is from the old batch, as the store had it for quite a while, and no one wanted it. I guess asians just don't collect much of British cars :giggle
 

·
Registered
Joined
·
4,471 Posts
Discussion Starter · #9 ·
I had pestered these guys close to 3 months now to get me this one. And now when it comes and I dont take it. lol There will be quite some sour faces next time I go there.
 

·
Advanced Newtype
Joined
·
1,710 Posts
Winston, can't they complain to the distributor and have them take it back and get you anotehr one? Especially with the defect on the rear lights, that's a legit reason...
 

·
Registered
Joined
·
4,471 Posts
Discussion Starter · #13 ·
Thanks for the replies guys. Gary, I called the hobby store and explained the problem. They will get another piece for me. So I got to wait a few more days. They being the importer, wholesaler,distributor and retailer themselves, its not a problem to get a good piece. Thats if AUTOart makes the models like they first appeared 2 years ago. Otherwise no one can help it.
 

·
Registered
Joined
·
4,471 Posts
Discussion Starter · #15 ·
Thanks Gary. Like I said, they are like family now. And if they see me coming back the next day after I have got a model, they get ready to give me a replacement of what I had taken the previous day. They dont call me "the replacement guy" for nothing. :giggle
 

·
Registered
Joined
·
7,424 Posts
Hope you get this sorted out, Winston. The XJ13 is a striking car.
BTW, mine has the stickers on the seatbelts too.
 

·
Registered
Joined
·
4,471 Posts
Discussion Starter · #18 ·
Thanks Luciano.
Got to be a combination of both Gary. Been unlucky with kits. Got a 2 front fenders in a Burago Alfa Romeo kit and two front bumpers in a Gate Peugeot 406 kit. Both had the rear parts missing. A Kyosho E class with 3 glue drops on the front fender. Makes me wonder if they purposely send the bad ones to India, atleast with the ready models. The kits were just bad QC.
 

·
Advanced Newtype
Joined
·
1,710 Posts
<{POST_SNAPBACK}>[/post][/right]
don't worry, I'm sure your luck will change! Maybe you'll find a hidden gem store in India, and find a bunch of old UT's! :giggle

I'm looking at you, Bernard! :happy
 

·
Advanced Newtype
Joined
·
1,710 Posts
I just checked my XJ13, I have the TOTAL labels on my seatbelts... The backlight looks fine as well. Weirdness...
 
1 - 20 of 21 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top